Урок 3-ий - Технические требования по установке Akeeba Backup для Joomla

В предыдущем уроке Вы познакомились с тем, что пользователи или покупатели расширения Akeeba Backup для Joomla сказали о том, как они его использовали и с их мнением о возможностях и поддержке этого компонента.

В этом блоге Вы узнаете о технических требованиях к установке актуальной версии Akeeba Backup для Joomla. Это поможет Вам избежать проблем при работе с ним в будущем.

Серверная среда

1) Актуальная версия Joomla. Вы сможете найти ее на официальной странице скачивания системы https://downloads.joomla.org. Это единственная страница в интернете которая всегда будет Вам предлагать только поддерживаемые и протестированные на предмет безопасности версии.
2) Версия PHP совместимая с Вашей версией Akeeba Backup. Полную таблицу совместимости версий компонента с версиями PHP можно найти по ссылке https://www.akeebabackup.com/compatibility.html. 

3) MySQL в версии 5.0.42 или версиях, следующих за ней. Для оптимальной работы рекомендуется версия MySQL 5.6 и более новые версии. MySQL 4.x не поддерживается.

4) Минимум 24 МБ памяти в PHP (достаточно только для небольших веб-сайтов, без большого числа установленных компонентов, модулей и плагинов). Еще больше, чем 24 МБ памяти будет даже лучше. 

Для оптимальной работы больших веб-сайтов рекомендуется от 32 МБ до 64 МБ. Для веб-сайтов содержащих крупные каталоги с большим числом категорий и тысячами файлов, рекомендуется 128 МБ.

Хотя расширение "Akeeba Backup" может работать на серверах с меньшей PHP памятью, процесс создания резервной копии веб-сайта в таких случаях скорее всего нарушится.

5) Достаточное незанятое дисковое пространство на сервере.

6) Для того, чтобы можно было работать с FTP и автоматически перемещать на облачные хранилища архивы Вашего веб-сайта по окончании создания его резервной копии, на Вашем веб-сервере должен быть установлен модуль PHP "cURL".

Ваш компьютер

Что касается браузеров, то Вы можете использовать следующие браузеры:

  • Internet Explorer 9 или новее (IE7 и IE6 не поддерживаются. Пользователи IE8, при резервировании больших веб-сайтов, могут столкнуться с хаотичными нарушениями процесса создания резервной копии своего веб-сайта)
  • Любые другие современные браузеры версия которых не старее одного года. Например, Microsoft Edge, Safari, Opera, Firefox или Google Chrome.

В любом случае, для того, чтобы процесс создания бэкапа прошел успешно, удостоверьтесь в том, что в Вашем брауере включен JavaScript. Если Вы используете антивирусную программу "AVG", то выключите, пожалуйста, ее функционал проверки ссылок "Link Checker" (и перезапустите свой компьютер).

Хорошо известно, что эта программа нарушает нормальную работу веб-приложений, работающих на JavaScript, включая расширение Joomla! "Akeeba Backup Pro" и входящие в него инструменты.

Настоятельно рекомендуется выключать для своего сайта сетевые экраны (Internet Firewalls), антивирусные приложения и расширения браузеров, которые вмешиваются в загрузку страниц Вашего сайта. Таких, к примеру, как блокираторы скриптов вроде NoScript и блокираторов рекламы, таких как AdBlockPlus.

Такие приложения и расширения браузеров предназначены защищать Вас от сторонних сайтов. В результате они очень агресивны и нарушат работу Вашего собственного сайта. 

Компонент Akeeba Backup для Joomla никаким контролем над ними не обладает. Ваш компьютер и Ваш браузер находятся целиком под Вашим собственным контролем.

​Русско-английский словарь урока

Русский English
​Технические требования ​Technical requirements
​Серверная среда`Server environment​
Версия PHP​PHP version​
​24 Мб памяти в РНР24 MB of PHP memory​
Модуль РНР cURL​PHP cURL module​
​Включить в моем браузере JavaScriptTo turn on JavaScript in my browser​
​Выключить сетевой экран​To turn firewall off

Дополнительное чтение

 

Комментарии

Еще нет комментариев
Уже зарегистрированны? Войти на сайт
Гость
16.07.2018

Изображение Captcha