Урок 2-ой - Что нужно знать новичку о техтребованиях по установке Joomla

 

Перед тем как Вы начнете работать с системой управления вебсайтами Джумла, Вам необходимо удостовериться в том, что для нее подготовлен надлежащий технический фундамент. 

Имеено такова цель сопровождающих технических требований по установке Джумла. В этом блоге Вы познакомитесь с их содержанием, с важностью их соблюдения и с тем, как их выполнить новичку.

Система Джумла как программное обеспечение, работает на нескольких технологиях. Пусть это слово не пугает Вас. И новичку и опытному владельцу сайта совсем не обязательно их подробно изучать. Вам лишь нужно быть в курсе их версий и знать какую роль номер их версии играет в бесперебойной работе Вашего вебсайта.

Microsoft или Open Source

Чтобы выполнить технические требования по установке Джумла, Вам достаточно уделить внимание трем главным технологиям: PHP, MySQL и Apache. Все три принадлежат инициативе Open Source. Все три, в отличии от аналогичного программного обеспечения от Microsoft, бесплатны. 

Если Вы изучите официальную страницу техтребований (https://downloads.joomla.org/ru/technical-requirements-ru), Вы заметите что кроме MySQL Джумла поддерживает две других базы данных: SQLServer от компании Microsoft и PostgreSQL [1]. Также, система поддерживает и два других вебсервера кроме Apache: Microsoft IIS и Nginx [2].

Первое решение которое Вам неизбежно предстоит принять это устанавливать ли свой сайт на PHP/MySQL/Apache или на PHP/SQLServer/IIS. Другими словами, выбрать ли для своего сайта программное обеспечение от Microsoft или от Open Source.

Я рекомендую Вам выбрать PHP/MySQL/Apache. Главным образом потому что Джумла традиционно лучше работает на них чем на технологиях от Microsoft.

Что есть что

PHP - это программное обеспечение, которое обрабатывает код страниц Вашего вебсайта на Джумла. MySQL - это программное беспечение базы данных для хранения содержания и настроек Вашего сайта. Apache - это программное обеспечение для работы вебсервера на котором будет установлен Ваш вебсайт.

Для соблюдения технических требований по всем трем Вам необходимо удостовериться в том, что версии всех трех на Вашем сайте соответствуют рекомендуемым. И прежде чем устанавливать Джумла и во все время жизни Вашего сайта.

Если Вы еще раз взглянете на официальную страницу техтребований, то Вы заметите, что для всех трех типов программного обеспечения существуют рекомендуемые и минимальные требования.
Я предлагаю выбирать для своего сайта версии в колонке "Рекомендуемые".

Номер версии и безопасность сайта

Почему важно чтобы версии PHP/MySQL/Apache, на которых работает Ваш вебсайт, соответствовали рекомендуемым официальными техническими требованиями? Ответ прост: "Потому что от этих версий зависит безопасность и защищенность Вашего вебсайта."

В моем блоге "Джумла принадлежит инициативе Open Source Software" я упомянул Вам, что код Joomla и код технологий PHP/MySQL/Apache, на которых она работает, открыт. Это предоставляет нам с Вами много выгод. Но это также содержит и опасность.

Дело в том, что старые и неподдерживаемые своими разработчиками версии этих технологий опасны и уязвимы. Актуальные на данный момент и поддерживаемые - нет. Это - голый факт который Вы всегда, всегда, всегда, всегда, всегда должны помнить.

Актуальная и поддерживаемая версия PHP/MySQL/Apache = безопасность и защита Вашего сайта на Джумла. Устаревшая и более не поддерживаемая = уязвимость и беззащитность Вашего сайта на Джумла.

Русско-английский словарь урока

Русский English
​Течнические требования ​Technical requirements
​Я должен выполнить технические требования по установке Джумла.
My Joomla installation must meet technical requirements​​/
​Версии порграммного обеспеченияSoftware versions​
Актуальные версии​Current version​
Неподдерживаемые версии программного обеспечения опасны и уязвимы.​​Unsupported versions of my software are unsecure and vulnerable.
Обновление PHP, MySQL, Apache и Джумла - первый шаг в​ безопасности моего сайт.Keeping my PHP, MySQL, Apache and Joomla versions up-to-date is the first step to securing my website.​
​Официальная страница с техтребованиями по установке ДжумлаOfficial technical requirement for Joomla installation​

Заключение

Отлично! Вы теперь знаете что прежде чем устанавливать Джумла местно или удаленно, Вам необходимо убедиться в том, что версии Вашего вебсервера, PHP и базы данных актуальны, согласно рекомендованных официальными техническихими требованиями по установке Джумла.

Дополнительное чтение

 

Комментарии

Еще нет комментариев
Уже зарегистрированны? Войти на сайт
Гость
22.09.2018

Изображение Captcha

Задать вопрос
1000 максимум символов